You will need Adobe Acrobat Reader 4.0 or greater in order to read our files.

EDI Specifications